Norton Internet Security logo

What version of NIS do you use? v1

May 3, 2011

In connection with the release of beta version of the Norton Internet Security 2012, I would like to know exactly which version of Norton Internet Security you use: 2012, 2011, 2010, 2009, 2008, 2007, 2006, 2005 or Norton Internet Security 4.0 for Macintosh. That is why, for 200 days ~1 year on all pages of this blog (right sidebar) you will see a poll with the help of which, we will try to find out the answer to the above question.

ps. Also, you can vote on this page.

0 comments: (+add yours?)

Post a Comment